Typeform incident update
Incident Report for Typeform
Resolved
We are glad to inform you that the fix has been implemented and the incident resolved. We will run a problem investigation to understand what happened and how to prevent it from happening again.

Thanks for your understanding & sorry for any inconvenience this has caused.
Posted Nov 17, 2020 - 10:02 CET
Identified
We are working on resolving errors in submitting forms impacting our renderer with high priority.

We are really sorry for any inconvenience this is causing. Next update in 15-20 minutes or as soon as it's available.

ZD - 428932 / TYP-3430
Posted Nov 17, 2020 - 09:53 CET
This incident affected: Forms.