Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 06, 2025 - 10:00 CET
Scheduled
Between the 6th and 10th January we’ll be performing a scheduled maintenance to our Homepage and all other public landing pages.
During the change window, users could experience some downtime with our public pages.
Note! This change does not impact Forms/Submissions nor Create/Admin Panel. You can access your Typeform Account via: https://admin.typeform.com/login/
Should you, after the change window, see any errors, latency or impact of any kind regarding typeform.com or other public pages, feel free to reach out to our Support Team on https://www.typeform.com/help/contact/
We will also be closely monitoring our systems and share further updates here if/when needed.
Posted Jan 02, 2025 - 10:18 CET
This scheduled maintenance affected: Public Pages (Pricing page, www.typeform.com, Blog, Public Template Gallery).