Typeform Platform login page is unavailable.
Incident Report for Typeform
Resolved
We are glad to inform that the incident is now resolved.

For users that still experience issues logging in, please clear your browsers cache.

We will run a problem investigation to understand the issue and avoid future recurrences.

Thanks for your understanding & apologies for any inconvenience.
Posted Jan 14, 2021 - 13:04 CET
Identified
We have identified errors impacting our login page. Some users trying to login to their workspace may be impacted. We are working on resolution with high priority.

Next update in 15-20 minutes or as soon as it's available.

REF: ZD #448647 | TYP-3887
Posted Jan 14, 2021 - 12:31 CET
This incident affected: Public Pages (www.typeform.com).