Help Center & Blog is Down
Incident Report for Typeform
Resolved
We're happy with our fix to bring our much loved Help Center and Blog back, so we're marking this incident as Resolved.

Apologies for the inconvenience caused and thank you for your patience while we investigated :)
Posted 6 months ago. Apr 03, 2019 - 13:04 CEST
Monitoring
We released a fix to bring our Help Center and Blog back. We will continue to monitor the situation for now to make sure it's all good :)
Posted 6 months ago. Apr 03, 2019 - 12:21 CEST
Investigating
Our wonderful Help Center & Blog are currently down. We are investigating to bring them back ASAP!

Don’t worry—your typeforms and related data aren’t affected. Typeforms are working as per usual. You can still log in at http://login.typeform.com.
Posted 6 months ago. Apr 03, 2019 - 11:59 CEST