Downloading files
Incident Report for Typeform
Resolved
We have resolved the issue so you will now be able to download your files from the results panel.
Posted 5 months ago. Jun 30, 2018 - 17:36 CEST
Identified
We are working on an issue affecting downloading files, we will share more information when we have another update.
Posted 5 months ago. Jun 30, 2018 - 13:31 CEST
This incident affected: Back-End.