Platform down
Incident Report for Typeform
Resolved
Thank you for your patience! The issue has now been resolved. If you have any questions, please feel free to reach out to our Support team at support@typeform.com.
Posted Jan 23, 2020 - 11:05 CET
Investigating
We are currently investigating an incident that caused an Error 50X on our platform and form access. We apologise for the inconvenience the issue has caused. If you have any questions, please contact support@typeform.com.
Posted Jan 23, 2020 - 10:47 CET
This incident affected: Forms / Renderer (Open/Load forms) and Back-End.