First 20 forms showing in Workspace
Incident Report for Typeform
Resolved
Thank you all for your patience. This has been resolved and all of your Workspaces and forms should be visible at this time.
Posted 2 months ago. Sep 10, 2018 - 19:11 CEST
Investigating
We are currently experiencing an issue where only the first 20 forms in a Workspace are showing. Our team is working to fix the issue ASAP.
Posted 2 months ago. Sep 10, 2018 - 18:27 CEST
This incident affected: Back-End.