Brief Outage
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 14 days ago. Nov 28, 2018 - 17:25 CET
Update
We are continuing to work on a fix for this issue.
Posted 14 days ago. Nov 28, 2018 - 17:25 CET
Identified
We had a brief outage of forms. The issue has been identified and the fix is being implemented, but forms are back to operational.
Posted 14 days ago. Nov 28, 2018 - 15:24 CET
This incident affected: Forms.