Issue with generating Reports
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 13, 2018 - 16:10 CEST
Investigating
We are currently investigating an issue with our Reports not being generating correctly.
Posted 4 months ago. Aug 13, 2018 - 15:56 CEST
This incident affected: Forms.