Saving changes to typeforms
Incident Report for Typeform
Resolved
We've resolved the issue and all form updates are now being saved
Posted Jul 25, 2018 - 15:16 CEST
Investigating
We are investigating an issue that is preventing changes made to a typeform from being saved.
Posted Jul 25, 2018 - 14:47 CEST
This incident affected: Forms / Renderer (Open/Load forms).