Typeform Help Center Contact Us Button Unavailable
Incident Report for Typeform
Resolved
We are glad to inform you that a fix has been implemented and the incident resolved. We will run an investigation to understand what happened and how to prevent it from happening again.

Thanks for your understanding & sorry for any inconvenience this has caused.
Posted Nov 13, 2020 - 09:58 CET
Identified
We have identified an error impacting our Help Center Contact Us button. Users trying to submit a new support request may be impacted. We are working on a resolution with a high priority.

As a workaround, please email our support team directly at support(at)typeform(dot)com.

Thank you for your patience and cooperation.
Posted Nov 13, 2020 - 00:10 CET
This incident affected: www.typeform.com.