Typeform Admin is down
Incident Report for Typeform
Resolved
At 4:02UTC we fixed the issue affecting admin. You can now access your account again.

We’re sorry if it affected you. We’re poring over things to make sure it doesn’t happen again.
Posted 3 months ago. Sep 20, 2018 - 18:09 CEST
Investigating
There’s some unscheduled downtime affecting our admin. We're looking into the issue and will update you shortly!
Posted 3 months ago. Sep 20, 2018 - 17:38 CEST
This incident affected: Back-End.