Typeforms are down
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Sep 25, 2018 - 14:55 CEST
Investigating
There’s some unscheduled downtime affecting our typeforms. Our best detectives are busy sleuthing to solve the case.
Posted Sep 25, 2018 - 14:51 CEST
This incident affected: Forms / Renderer (Open/Load forms).