The Results page showing "No signs of movements"
Incident Report for Typeform
Resolved
Thank you for your patience. The issue has been resolved.
Posted 5 months ago. Jan 23, 2019 - 15:59 CET
Investigating
We are currently investigating an issue in which the results page shows "No signs of movements" when the typeform has collected responses. We will be keeping you posted. Please accept our apologies for any inconvenience caused.
Posted 5 months ago. Jan 23, 2019 - 14:33 CET
This incident affected: Forms.