Typeform Admin is down
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 16, 2018 - 17:54 CEST
Investigating
There’s some unscheduled downtime affecting our admin. Our best detectives are busy sleuthing to solve the case.
Posted about 2 months ago. Oct 16, 2018 - 17:36 CEST
This incident affected: Back-End.