Typeform Admin panel is currently degraded.
Incident Report for Typeform
Resolved
We are glad to inform you that this incident has been resolved. We will run a problem investigation to understand what happened and how to prevent it from happening again.

Thanks for your understanding & sorry for any inconvenience this has caused.
Should you have any questions or experience a new issue, please feel free to reach out at support@typeform.com
Posted Mar 17, 2021 - 18:47 CET
Update
We continue working on resolving the error impacting some users' ability to log into their admin panel. As of now, we have identified the root cause for this incident and the fix is being applied now.

Accept our apologies for any inconvenience this is causing. We'll share another update in 15-20 minutes or as soon as it's available.
Posted Mar 17, 2021 - 17:45 CET
Identified
We have identified errors impacting our log-in to admin panel. Some users have issue logging in. We are working on resolution with high priority.

Next update in 15-20 minutes or as soon as it's available.

REF: ZD 469413 | TYP-TYP-4222
Posted Mar 17, 2021 - 17:13 CET
This incident affected: www.typeform.com.