Account - Plan & Billing Page is down
Incident Report for Typeform
Resolved
We resolved that pretty fast! The Plan & Billing page is back.
Posted 22 days ago. Nov 20, 2018 - 15:39 CET
Investigating
We are aware our Plan & Billing page on the platform is currently down. We are working hard to get it back for you ASAP!
Posted 22 days ago. Nov 20, 2018 - 15:37 CET
This incident affected: Back-End.