Help Center Downtime
Incident Report for Typeform
Resolved
Thank you for your patience! Our engineers have brought our Help Center back to life. Please let us know if you have any questions.
Posted 5 months ago. Apr 10, 2019 - 15:43 CEST
Investigating
Our Help Center is currently down at the moment. Our engineers have identified the issue and they are currently working on a fix. Please accept our apologies for any inconvenience this may cause! If you have any questions, please contact support@typeform.com.
Posted 5 months ago. Apr 10, 2019 - 15:12 CEST
This incident affected: www.typeform.com.