Builder screen turns blank when clicking on Logic Jumps
Incident Report for Typeform
Resolved
The you for your patience while we worked on issue. The issue has now been resolved.
Posted 30 days ago. Jan 21, 2019 - 15:30 CET
Investigating
We are currently investigating an issue in which the builder screen turns blank when clicking on Logic Jumps. We'll be keeping you updated. Thank you for your understanding and patience.
Posted about 1 month ago. Jan 21, 2019 - 14:54 CET
This incident affected: Forms.