Checkout Page down
Incident Report for Typeform
Resolved
A fix has been deployed. Thank you very much for your patience while we investigated the issue!
Posted 13 days ago. Nov 29, 2018 - 15:28 CET
Investigating
We’ve received reports that users are not able to make payments on our checkout page. We are investigating the issue at the moment and we’ll keep you posted. Please accept our apologies for the inconvenience this may caused.
Posted 13 days ago. Nov 29, 2018 - 14:13 CET
This incident affected: Back-End.