There's a delay capturing submissions
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 10, 2019 - 23:27 CET
Monitoring
We have identified the issue and are monitoring the submissions.
Posted 2 months ago. Jan 10, 2019 - 23:16 CET
Investigating
We're investigating an issue in which some respondents are unable to submit forms. Thanks for your patience. We’re on it, and we’ll update you asap.
Posted 2 months ago. Jan 10, 2019 - 23:14 CET
This incident affected: Forms.