Response Deletion Error
Incident Report for Typeform
Resolved
We have found the fix for our response deletion error! You should now be able to delete your responses again from the results panel :)

If you encounter any more issue, please do reach out to us at support@typeform.com and we'll be happy to help.

Thank you for your patience and understanding while we investigating this!
Posted 13 days ago. Oct 03, 2019 - 15:36 CEST
Investigating
We are currently investigating an issue whereby our users are unable to delete responses from the Results panel.

Our engineers are on the case and are working hard to reach a resolution!

We apologise for the inconvenience this is causing. Please reach out to support@typeform.com if you have any questions.
Posted 13 days ago. Oct 03, 2019 - 14:46 CEST
This incident affected: Back-End.