Comcast blocking Typeform requests
Incident Report for Typeform
Resolved
After several repeated conversations with Comcast's security department, they have managed to lift their block on requests to Typeform.com.
Comcast customers can now access Typeform and their typeforms as normal.
Posted Feb 06, 2015 - 00:24 CET
Update
Update (Comcast incident):

We've confirmed that today, the ISP Comcast, took the ridiculous step of blocking Typeform due to a reported phishing case using their brand. We resolved the case as soon as they reported it to us a few days ago, however they still took the unprecedented step to block our domain without any warning today. This means that anyone that is using the Comcast network today can't access Typeform.

We've now spoken to Comcast on the phone and they say it will take up to 24 hours to unblock. We're trying through our network of contacts to reduce this time by as much as we can.

We're feeling your pain (Comcast users)!
Posted Feb 05, 2015 - 19:13 CET
Monitoring
Update: We suspect that the issues we're currently experiencing are due to connectivity problems with the ISP Comcast and therefore isolated to users on that network. We've had several reports from users that are using Comcast that can't log in or load typeforms.
Posted Feb 05, 2015 - 18:36 CET
Identified
We have found more cases and we are currently trying to pinpoint the issue
Posted Feb 05, 2015 - 17:26 CET
Monitoring
We have fixed the issue but we are currently monitoring in case there are any further isolated cases
Posted Feb 05, 2015 - 17:22 CET
Investigating
We encountered an issue related with login into the application and in some cases, issues when visiting a typeform.

We are currently investigating the incident and we are doing our best to resolve this issue as soon as possible.
Posted Feb 05, 2015 - 17:07 CET