Typeform Admin and typeforms are degraded
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 19:21 CET
Monitoring
A fix has been implemented and we are monitoring the results. Thanks for your patience.
Posted Jan 31, 2020 - 18:55 CET
Investigating
There’s some unscheduled downtime affecting our typeforms and admin. We are looking into the issue.
Posted Jan 31, 2020 - 18:51 CET
This incident affected: Forms and Back-End.