Typeform Admin is down
Incident Report for Typeform
Resolved
At 17:08 UTC we fixed the issue affecting admin, due to an issue with internal service connectivity. You can now access your account again.

Thank you for your patience!
Posted 5 months ago. May 08, 2019 - 19:14 CEST
Investigating
There’s some unscheduled downtime affecting our admin. We're looking into this issue and hope to have an update for you soon.
Posted 5 months ago. May 08, 2019 - 18:55 CEST
This incident affected: Back-End.