Typeform Admin and typeforms are down
Incident Report for Typeform
Resolved
At 16:25 UTC we fixed the issue affecting admin and typeforms. You can now access your account and typeforms again.

We'll continue investigating this issue, to avoid future incidents.
Posted Nov 19, 2019 - 17:26 CET
Investigating
There’s some unscheduled downtime affecting our admin and typeforms. We're looking into this right now.
Posted Nov 19, 2019 - 17:17 CET
This incident affected: Forms / Renderer (Open/Load forms) and Back-End.