Typeform Admin and forms are degraded
Incident Report for Typeform
Resolved
We fixed the issue affecting admin and typeforms. Thanks for your patience!
Posted Jan 09, 2020 - 19:13 CET
Investigating
There’s some unscheduled downtime affecting our admin and forms. We're investigating the cause.
Posted Jan 09, 2020 - 18:31 CET
This incident affected: Forms and Back-End.