Typeform Admin and typeforms are down
Incident Report for Typeform
Resolved
Normal service has been restored.
Posted Sep 20, 2018 - 00:55 CEST
Investigating
There’s some unscheduled downtime affecting our admin and typeforms. Our best detectives are busy sleuthing to solve the case.
Posted Sep 19, 2018 - 23:23 CEST
This incident affected: Forms / Renderer (Open/Load forms) and Back-End.