Results delayed
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 26, 2019 - 05:57 CEST
Update
All results are now being displayed as expected.
Posted 4 months ago. Jun 26, 2019 - 05:56 CEST
Investigating
We had an issue with results being delayed. Right now we are processing all the queued results to get back to normality.
Posted 4 months ago. Jun 26, 2019 - 05:42 CEST
This incident affected: Forms.