The Blog is down
Incident Report for Typeform
Resolved
Our blog www.typeform.com/blog is now back up and running. Your typeforms and data weren’t affected.

We’re looking into the problem—and taking a lightsaber to what caused it.
Posted 4 months ago. Mar 12, 2019 - 23:19 CET
Investigating
Our blog http://typeform.com/blog is down.

We’re looking into the problem. Don’t worry—your typeforms and related data aren’t affected. Typeforms are working as per usual. You can still log in at http://login.typeform.com.

Sorry about this. We’ll post an update asap.
Posted 4 months ago. Mar 12, 2019 - 22:36 CET
This incident affected: www.typeform.com.