Typeform subscriptions and typeforms with payment fields are degraded
Incident Report for Typeform
Resolved
Stripe's services have been restored, so we are marking this incident as Resolved.

You should now be able to subscribe to our plans, upgrade and respond to forms with the payment field.

Thank you for your patience while we worked through this issue! If you have any questions you can reach out to us at support@typeform.com.
Posted about 1 month ago. Jul 11, 2019 - 09:30 CEST
Update
Our functionality is restored, but we will monitor the situation.
Posted about 1 month ago. Jul 10, 2019 - 23:51 CEST
Monitoring
Our payment processor is having some downtime (https://status.stripe.com/) This will affect subscribing to our plans and responding to typeforms with payment fields.
Posted about 1 month ago. Jul 10, 2019 - 23:43 CEST
This incident affected: Forms.