Missing Responses & Trouble Accessing Workspaces
Incident Report for Typeform
Resolved
Thank you for your patience while we investigated and fixed the issues with workspaces and results.

You should now be able to access your forms and view your responses again.

Apologies for this disruption. If you have any questions, you can reach out to us at support@typeform.com and we'll be happy to help.
Posted 17 days ago. Sep 04, 2019 - 17:28 CEST
Investigating
We are currently investigating issues around accessing typeforms in workspaces and viewing Results.

Our Engineers are on the case to bring things back.

Apologies for the inconvenience caused, we'll make sure to keep you updated.

Please reach out to us at support@typeform.com if you have any questions.
Posted 17 days ago. Sep 04, 2019 - 17:11 CEST
This incident affected: Back-End.