ERROR 400 on Login page
Incident Report for Typeform
Resolved
The issue has now been resolved. Thank you for your patience!
Posted 8 months ago. Jan 21, 2019 - 15:23 CET
Investigating
We are working on fixing an issue regarding Error 400 on our Login page. We will keep you updated.
Thank you for your patience.
Posted 8 months ago. Jan 21, 2019 - 15:17 CET
This incident affected: www.typeform.com.