Login error
Incident Report for Typeform
Resolved
We have now resolved the issue and all users can log in to their account
Posted about 1 year ago. Nov 21, 2017 - 17:10 CET
Investigating
We are investigating an issue that is preventing users from logging in to their account. As soon as we have more information we will provide an update
Posted about 1 year ago. Nov 21, 2017 - 17:01 CET