Typeform Platform currently degraded
Incident Report for Typeform
Resolved
We are glad to inform you that a fix has been implemented and the incident resolved. We will run a problem investigation to understand what happened and how to prevent it from happening again.

Thanks for your understanding & sorry for any inconvenience this has caused.
Posted Nov 12, 2020 - 13:28 CET
Identified
We have identified errors impacting our platform. Users across the platform may be impacted. We are working on resolution with high priority.

Next update in 15-20 minutes or as soon as it's available.

REF: ZD427628 | TYP-TYP-3416
Posted Nov 12, 2020 - 13:15 CET
This incident affected: Forms and Back-End.