Issues with Notification Emails
Incident Report for Typeform
Resolved
We are happy to report that all Notifications are now working and we have sent those that were delayed as well. We apologize for any inconvenience this may have caused.
Posted Jan 19, 2018 - 23:35 CET
Investigating
Typeform cannot send any email Notifications because of an issue with our email provider. We are looking into the issue and working on restoring service as soon as possible!
Posted Jan 19, 2018 - 21:57 CET