Result submission delay
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Jul 16, 2015 - 01:12 CEST
Identified
Some users may experience delays is the submission of results. We are aware of the issue and it will be resolved shortly. Please be reassured that none of your results are lost.
Posted Jul 15, 2015 - 23:03 CEST