Typeform Admin or typeforms are down
Incident Report for Typeform
Resolved
At 15:21 UTC we fixed the issue affecting typeforms and you can now access them

We’re sorry if it affected you. We’re poring over things to make sure it doesn’t happen again.
Posted 12 days ago. Feb 12, 2018 - 15:26 CET
Investigating
There’s some unscheduled downtime affecting our admin and typeforms. Our best detectives are busy sleuthing to solve the case.
Posted 12 days ago. Feb 12, 2018 - 15:18 CET