Typeform unscheduled downtime
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Oct 01, 2015 - 14:29 CEST
Update
The issue with the Admin platform and typeforms was fixed and we're back to normal.

We are deeply sorry for the inconvenience. The issue was due to Amazon's ElsaticCache issue. We will work with Amazon to prevent this from occurring again in the future.

Here is a link to Amazon's issue: https://twitter.com/aws_shd/status/649558542119145473
Posted Oct 01, 2015 - 14:28 CEST
Investigating
We are investigating unscheduled downtime affecting the Typeform admin and typeforms. We're working to resolve this as quickly as possible.
Posted Oct 01, 2015 - 13:47 CEST