Data Processing Delays
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 13, 2017 - 01:09 CET
Investigating
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted 6 months ago. Feb 13, 2017 - 00:32 CET