Results Temporarily Delayed
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 09, 2017 - 19:20 CET
Investigating
We are currently experiencing a temporary delay in results. We're working to resolve this as quickly as possible.
Posted 5 months ago. Mar 09, 2017 - 18:52 CET