Maintenance
Incident Report for Typeform
Resolved
All systems working properly
Posted Feb 09, 2014 - 08:45 CET
Identified
We are doing some maintenance to our backend servers that will affect all our forms.
Posted Feb 09, 2014 - 08:26 CET