Forms and Admin are currently unavailable
Incident Report for Typeform
Resolved
The issue has been resolved and you will now be able to access your forms and the builder.
Posted 11 months ago. Jan 16, 2017 - 15:31 CET
Investigating
We are aware of an issue affecting forms and the typeform builder. We are investigating at the moment and will provide a further update shortly.
Posted 11 months ago. Jan 16, 2017 - 15:18 CET