Full outage
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 9 days ago. Sep 11, 2018 - 12:08 CEST
Update
Normal service has been restored.
Posted 9 days ago. Sep 11, 2018 - 12:08 CEST
Investigating
We are currently experiencing an issue across all of the platform and are working to resolve.
Posted 9 days ago. Sep 11, 2018 - 11:58 CEST
This incident affected: Forms, Back-End, and Notifications.