Logic Jumps editor not available
Incident Report for Typeform
Resolved
The issue is currently fixed, users are able to create and edit their logic jumps as they please.
Our apologies for the inconveniences caused.
Posted Sep 14, 2015 - 17:22 CEST
Identified
We are experiencing an issue that is hiding previously created logic jumps on the Logic Jump panel of questions, so users can create jumps but not edit them (logic jumps themselves have not been affected and they are working as expected).

The issue has been identified and a fix is underway.
Posted Sep 14, 2015 - 15:51 CEST