Issues with Welcome Screens and Images
Incident Report for Typeform
Resolved
We have fixed the issue and no form content has been modified or lost.

We are sorry if this issue has caused any inconvenience.
Posted Jan 30, 2015 - 16:12 CET
Monitoring
We have identified an issue with using images inside Welcome Screens and fixed the issue. We are still monitoring for new issues but we feel confident that the issue has been fixed.

We are sorry for any inconvenience this may have created. We can ensure you that no data regarding your form or results have been affected in any way.
Posted Jan 30, 2015 - 10:25 CET