Typeform Platform Down
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 28, 2017 - 16:08 CEST
Investigating
We're currently experiencing issues. We appreciate your patience while we investigate and will provide an update as soon as possible.
Posted over 1 year ago. Jun 28, 2017 - 16:04 CEST