Issues with form
Incident Report for Typeform
Resolved
Our forms are now operational again as the Amazon EC2 maintenance is now complete.
Posted 9 months ago. Jan 03, 2018 - 20:42 CET
Identified
We are experiencing temporary downtime to our forms, based on Amazon EC2 maintenance. We expect them to be back up very soon.

We are sorry for the inconvenience.
Posted 9 months ago. Jan 03, 2018 - 20:38 CET