Help Center unavailable
Incident Report for Typeform
Resolved
Our Help Center is now available and we will be investigating the cause behind this.
Posted 9 months ago. Mar 14, 2017 - 15:05 CET
Investigating
We are experiencing an issue where our Help Center is unavailable.

We are currently investigating the cause, but rest assured this does not affect the Typeform platform, your typeforms, or their data. You can still log in at http://login.typeform.com and your typeforms will continue to work as before.

We hope to bring the site back online very soon.
Posted 9 months ago. Mar 14, 2017 - 14:56 CET