Admin Issue
Incident Report for Typeform
Resolved
The issue has now been resolved. We apologise for the inconvenience!
Posted Sep 12, 2016 - 17:51 CEST
Investigating
We are aware that some users are seeing an error message in Typeform Admin. Our team are investigating the issue and we will provide a further update as soon as possible.
Posted Sep 12, 2016 - 17:40 CEST